Menu
Menu
Netgear and ZyXEL confirm NetUSB flaw, are working on fixes

Netgear and ZyXEL confirm NetUSB flaw, are working on fixes

The vulnerability could allow attackers to take over affected routers

Netgear Nighthawk AC1900 Smart WiFi Router

Netgear Nighthawk AC1900 Smart WiFi Router

Networking device manufacturers ZyXEL Communications and Netgear have confirmed that some of their routers are affected by a recently disclosed vulnerability in a USB device-sharing service called NetUSB.

ZyXEL will begin issuing firmware updates in June, while Netgear plans to start releasing patches in the third quarter of the year.

The vulnerability, tracked as CVE-2015-3036, is located in a Linux kernel module called NetUSB that's commonly used in routers and other embedded devices. The module is developed by a Taiwan-based company called KCodes Technology and allows routers to share USB devices with other computers via the Internet Protocol (IP).

Researchers from a company called Sec Consult found a buffer overflow vulnerability in the NetUSB service, which listens for connecting clients on TCP port 20005. The vulnerability can be exploited to execute malicious code on vulnerable devices with the highest possible privilege, leading to a complete compromise.

Based on firmware scans, the Sec Consult researchers believe that over 90 products from D-Link, Netgear, TP-Link, Trendnet and ZyXEL are likely vulnerable. Products from 21 other vendors might be affected as well.

Only TP-Link had begun to release patches by the time the vulnerability was publicly disclosed Tuesday, but many other manufacturers had received advanced notice through the CERT Coordination Center.

The vulnerability, which concerns the ReadySHARE feature in Netgear products, can only be exploited from inside the local area network, not remotely from the Internet, Netgear said in an emailed statement.

The company has not yet revealed the number of affected products or their names, but said that it plans to start releasing firmware updates in the third quarter of the year.

That's quite a long time for Netgear routers to remain vulnerable, considering that there is no workaround available. The NetUSB service can't be manually disabled on Netgear routers and the port it uses cannot be firewalled, the Sec Consult researchers said in a blog post.

Netgear said its customers should make sure that Wi-Fi security is turned on, which is the default setting on its routers and gateways. It also recommends that they change the default password for the router to prevent unauthorized devices from accessing their network.

That advice might be of little use to small businesses like bars or restaurants that might be using Netgear routers and need to share the Wi-Fi password with customers and guests.

Even on home networks, where access is more strictly controlled, if attackers compromise a computer that's inside the network -- for example, through malware -- they could use it to compromise the router from within.

Netgear advised users to scan their computers for malware regularly and to enable the firewall feature in their operating systems as a precaution.

ZyXEL has developed a fix for the vulnerability and is in the process of rebuilding the NetUSB modules, a company representative said Thursday via email.

The company has identified four affected products and estimates that patches for them will be released in June. The affected products have not been named, but the company is working on a public announcement about the issue.

The Sec Consult advisory names 38 products from Netgear, 39 from TP-Link, 14 from Trendnet, 4 four ZyXEL and 1 from D-Link that are likely vulnerable. However, the list is likely incomplete, the researchers said.

According to the advisory, TP-Link has already provided a release schedule and plans to release firmware updates for most of its affected products by the end of May. However, there are also five affected TP-Link routers that have reached end-of-life and will most likely not receive patches. That will probably also be the case with some affected devices from other manufacturers. Networking device manufacturers ZyXEL Communications and Netgear have confirmed that some of their routers are affected by a recently disclosed vulnerability in a USB device-sharing service called NetUSB.

ZyXEL will begin issuing firmware updates in June, while Netgear plans to start releasing patches in the third quarter of the year.

The vulnerability, tracked as CVE-2015-3036, is located in a Linux kernel module called NetUSB that's commonly used in routers and other embedded devices. The module is developed by a Taiwan-based company called KCodes Technology and allows routers to share USB devices with other computers via the Internet Protocol (IP).

Researchers from a company called Sec Consult found a buffer overflow vulnerability in the NetUSB service, which listens for connecting clients on TCP port 20005. The vulnerability can be exploited to execute malicious code on vulnerable devices with the highest possible privilege, leading to a complete compromise.

Based on firmware scans, the Sec Consult researchers believe that over 90 products from D-Link, Netgear, TP-Link, Trendnet and ZyXEL are likely vulnerable. Products from 21 other vendors might be affected as well.

Only TP-Link had begun to release patches by the time the vulnerability was publicly disclosed Tuesday, but many other manufacturers had received advanced notice through the CERT Coordination Center.

The vulnerability, which concerns the ReadySHARE feature in Netgear products, can only be exploited from inside the local area network, not remotely from the Internet, Netgear said in an emailed statement.

The company has not yet revealed the number of affected products or their names, but said that it plans to start releasing firmware updates in the third quarter of the year.

That's quite a long time for Netgear routers to remain vulnerable, considering that there is no workaround available. The NetUSB service can't be manually disabled on Netgear routers and the port it uses cannot be firewalled, the Sec Consult researchers said in a blog post.

Netgear said its customers should make sure that Wi-Fi security is turned on, which is the default setting on its routers and gateways. It also recommends that they change the default password for the router to prevent unauthorized devices from accessing their network.

That advice might be of little use to small businesses like bars or restaurants that might be using Netgear routers and need to share the Wi-Fi password with customers and guests.

Even on home networks, where access is more strictly controlled, if attackers compromise a computer that's inside the network -- for example, through malware -- they could use it to compromise the router from within.

Netgear advised users to scan their computers for malware regularly and to enable the firewall feature in their operating systems as a precaution.

ZyXEL has developed a fix for the vulnerability and is in the process of rebuilding the NetUSB modules, a company representative said Thursday via email.

The company has identified four affected products and estimates that patches for them will be released in June. The affected products have not been named, but the company is working on a public announcement about the issue.

The Sec Consult advisory names 38 products from Netgear, 39 from TP-Link, 14 from Trendnet, 4 four ZyXEL and 1 from D-Link that are likely vulnerable. However, the list is likely incomplete, the researchers said.

According to the advisory, TP-Link has already provided a release schedule and plans to release firmware updates for most of its affected products by the end of May. However, there are also five affected TP-Link routers that have reached end-of-life and will most likely not receive patches. That will probably also be the case with some affected devices from other manufacturers.

Join the CIO Australia group on LinkedIn. The group is open to CIOs, IT Directors, COOs, CTOs and senior IT managers.

Join the CIO newsletter!

Error: Please check your email address.

Tags patchesintrusionsecurityTRENDnetnetgearZyXEL CommunicationsD-LinkExploits / vulnerabilitiesTP-Link

More about LinuxTechnologyTP-LinkZyXEL

Show Comments
Computerworld
ARN
Techworld
CMO