Microsoft Patch Tuesday addresses Exchange and Explorer flaws

Microsoft Patch Tuesday addresses Exchange and Explorer flaws

Microsoft issued 7 security patches for the month

Internet Explorer and Exchange Server top the list of Microsoft programs needing to be patched by IT administrators this month, now that the company has rolled out its latest round of "Patch Tuesday" security fixes.

Overall, Microsoft has issued seven security bulletins for December, including three that are critical, covering security vulnerabilities found in Windows (both the server and desktop editions), Office, Exchange Server, SharePoint Server and Internet Explorer.

The first bulletins administrators should look at are those that make remote code execution (RCE) possible, said Wolfgang Kandek, chief technology officer for IT security firm Qualys. These patches fix the vulnerabilities in the software that would allow an attacker to execute commands from across a network.

One bulletin, MS14-084, fixes an RCE vulnerability found in the Windows VBScript engine. MS14-80 fixes RCE issues in Internet Explorer.

Other bulletins -- MS14-081, MS14-082, MS14-083 -- tackle RCE vulnerabilities in Microsoft Office.

Microsoft is not alone in fending off potential RCE attacks. Adobe also issued two critical patches Tuesday covering RCE vulnerabilities in its Adobe Flash, Reader and Acrobat software packages. Users of Chrome and Internet Explorer have their versions of Flash updated automatically; those using other browsers will have to update their machines manually.

Beyond RCE attacks, administrators who allow users to access Microsoft Exchange email through a Web client should make a priority of testing and installing the Microsoft MS14-075 patches. This bulletin fixes four vulnerabilities that could be exploited by maliciously crafted websites.

"If you use Outlook Web Access, then you might want to take a look at that," Kandek said.

Microsoft originally scheduled to release this bulletin for Exchange last month, but held it for additional testing. Unlike the critical Kerberos flaw discovered last month, for which Microsoft rushed out an unscheduled patch, the vulnerabilities covered by this bulletin have not yet been used by attackers, Kandek said.

Beyond Microsoft and Adobe, administrators should also be sure they are up to date on the latest with the POODLE (Padding Oracle On Downgraded Legacy Encryption) vulnerability, first discovered in October in older versions of the SSL (Secure Sockets Layer) encryption software.

On Monday, Google researchers announced that POODLE also affects the more widely used TLS (Transport Layer Security) encryption software. Even if an organization does not use TLS directly, the protocol may be embedded in other systems, such as load balancers, Kandek said.

Microsoft has issued 85 bulletins this year, down from 106 in 2013.

Joab Jackson covers enterprise software and general technology breaking news for The IDG News Service. Follow Joab on Twitter at @Joab_Jackson. Joab's e-mail address is

Join the CIO Australia group on LinkedIn. The group is open to CIOs, IT Directors, COOs, CTOs and senior IT managers.

Join the CIO newsletter!

Error: Please check your email address.

Tags patchesMicrosoftsecurityDesktop securitypatch managementExploits / vulnerabilities

More about GoogleIDGMicrosoftNewsOracleQualysTransport

Show Comments